技术支持 Support
联系方式 Contact

云ag改路单|注册公式网

淘宝:zb-mart.taobao.com

电话:18020657357

Q Q:396950280

网址:www.yzhibiao.com

搜索 Search
你的位置:首页 > 技术支持 > 公式改编

股票公式编写常用的表达写法[简]

2014-10-14 11:58:25点击:

代理编写(对转)通达信 飞狐 同花顺 大智慧 文华财经 博易大师 依天财经等软件ag改路单|注册!

一、放量、缩量(成交量函数为VOL)
1、放量:
(1).今天成交量较昨天增加了1倍,表示如下:
  ?VOL/REF(VOL,1)>2
(2).今天成交量较10个交易日平均成交量放大了1倍,表示如下:
a:=ma(vol,10);
Vol/a>2
或者直接用如下公式表示:
vol/ma(vol,10)>2;
(3).今日的5日均量较10个交易日平均成交量放大了1倍,表示如下:
 ?a:=ma(vol,10);
b:=ma(vol,5);
b/a>2;
(4).今日的成交量超过了整个流通盘的5%,表示如下:
  ?vol/capital>0.05;其中capital代表流通盘。
2、缩量
 ?(1).今日成交量较昨日减少了一半,表示如下:
vol/ref(vol,1)<0.5;
(2).今日成交量较10个交易日平均成交量减少一倍,表示如下:
 ?a:=ma(vol,10);
vol/a<2;
或者直接用如下公式表示:
  ?vol/ma(vol,10)<2;
(3).今日的5日均量较10个交易日平均成交量减少1倍,表示如下:
a:=ma(vol,10);
b:=ref(a,5);
a/b<2;
(4).今日的成交量低于了整个流通盘的5%,表示如下:
vol/capital<0.05;
二、上涨、下跌
上涨:
今天的涨幅达到5%以上,表示如下:
close/ref(close,1)>1.05;
5日均价连续上涨,表示如下:
a:=ma(close,5);
b:=ref(a,1);
b;
下跌:
今天的跌幅达到5%以上,表示如下:
close/ref(close,1)<0.95;
5日均价连续下跌,表示如下:
a:=ma(close,5);
b:=ref(a,1);
a<>
(3)、K线的描述
close>open;阳线
close<>
open>ref(close,1);高开
open<>
open>ref(high,1);跳空高开(high为最高价)
open<>
三、走势特征选股公式的编制
(1)、n日内创新高
  ?hhv(high,n)=hhv(high,0)?and?barscount(c)>=n;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。Hhv(x,n),求n周期内x最高值,n=0则从第一个有效值开始;barscount(x),将当前位置到n周期前的数值设为1,若x非0,则将当前位置到n周期前的数值设为1。
(2)、n日内创新低
  ?llv(low,n)=llv(low,0)?and?barscount(close)>=n;
注n为ag改路单|注册参数,可在参数设定范围内设定参数范围。Llv(x,n),求n周期内x最低值,n=0则从第一个有效值开始;barscount(x)第一个有效数据到当前的天数,例如,barscount(close)以于日线数据取得上市以来总交易日数。
(3)、n日内阴线多于阳线
  ?count(open>close,n)/n<0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等 ,达到确定阴线占全部K线个数的比例)。
(4)、n日内阳线多于阴线
   count(open0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等 ,达到确定阳线占全部K线个数的比例)。
(5)、n日内上涨多于下跌(第二天开盘高于前一天收盘)
count(c>ref(c,1),n)/n>0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等 ,达到确定其中比例)。
(6)、n日内上涨少于下跌(第二天开盘低于前一天收盘)
  ?count(c>ref(c,1),n)/n<0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等,达到确定其中比例)。
(7)、连续n日收阳线
 ?up:=close>open;
count(up,n)=n;
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。n为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(8)、连续n日内收阴线
 ?up:=close<>
count(up,n)=n;
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。N为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(9)、连续n天上涨
   count(close>ref(close,1),n)=n;
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。N为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(10)、连续n天下跌
  count(c<>
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。N为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(11)、首次创新高
   barssince(c>hhv(if(barscount(c)=1,high,0),0))+1=1;
注:barscount(x),若x非0,则将当前位置到n周期前的数值设为1。
(12)、创历史新高
   hhv(close,0)=close;
注:hhv(x,n),求n周期内x最高值,n=0则从第一个有效值开始。
(13)、创历史新低
   llv(close,0)=close;
注:llv(x,n),求n周期内x最小值,n=0则从第一个有效值开始。
(14)、单日放量
 ?a:=ref(ma(vol,5),1);
vol/a>n?and?vol/capital*100>m;
注:n为ag改路单|注册参数,代表今日成交量和前一日的5日均量的比值,可在参数设定范围内设定参数范围。
(15)、阶段缩量
   sum(vol,n1)/capital<=n2;
注:n1为要统计的阶段时间,n2为缩量比例,可在参数设定范围内设定参数范围。
(16)、阶段放量
   sum(vol,n1)/capital>=n2;
注:n1为要统计的阶段时间,n2为y放量比例,可在参数设定范围内设定参数范围。
(17)、持续放量
 ?a:=vol>ref(vol,1);
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日放大,n为要统计的阶段时间,可在参数设定范围内设定参数范围。
(18)、持续缩量
 ?a:=vol<>
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日缩小,n为要统计的阶段时间,可在参数设定范围内设定参数范围。
(19)、间隔放量
 ?a:=ma(vol,5);
barscount(c)>=n?and?hhv(a,n)n2*a,n)>n3;
注:a.barscount(x)第一个有效数据到当前的天数。Barscount(c)对于日线数据取得上市以来总交易日数。
b.完整含义:n日内五日均量的最大值小于最小值的n1倍,成交量大于等于五日均量的n2倍的情况发生的次数多于n3次。
(20)、放量上攻
a:=(c-ref(c,1))/ref(c,1)>=(n/100);
sum(vol,n1)/capital>=(n2/100)?and?count(vol>ref(vol,1),n3?)=n3?and?count(a,n3)=n3;
完整含义:每日股价涨幅均大于n%,n1日内累计换手率大于n2%,并且成交量连续在n3日内放大。
(21)、温和放量上攻
   股价小幅上扬
a1:=close/ref(close,1);
a2:=a1>1?and?a1<1.03;
成交量小幅上扬
   b1:=vol/ref(vol,1);
b2:=b1>1?and?b1<2;
c1:=ma(vol,n)/capital<0.05;
count(a2?and?b2,n)/n>0.6?and?c1;
完整公式为:
 ?a1:=close/ref(close,1);
a2:=a1>1?and?a1<1.03;
b1:=vol/ref(vol,1);
b2:=b1>1?and?b1<2;
c1:=ma(vol,n)/capital<0.05;
count(a2?and?b2,n)/n>0.6?and?c1;
注:公式分为股价小幅上扬和成交量小幅上扬两个部分,请在ag改路单|注册编写时注意其结构。
(22)、突然放量
   vol>ref(hhv(vol,n),1*m;
注:当前成交量高于n个周期中最大成交量的m倍。
(23)、平台整理
   count(close,0)>n?and?(hhv(close,n)-llv(close,n))v(close,n)<=(n1/100);
注:count(close,0)>n为平台整理n个周期的设定。(hhv(close,n)-llv(close,n))v(close,n)<=(n1/100)为平台整理幅度n1%的设定。
(24)、突破长期盘整
ref(((hhv(h,n)-llv(l,n))v(l,n))v(l,n)),1)<=(n1/100)?and?c>=ref(hhv(h,n),1)?and?barscount(c)>n;
注:前n日在上下n1%的幅度内整理:ref(((hhv(h,n)-llv(l,n))v(l,n))v(l,n)),1)<=(n1/100);
今日突破:c>=ref(hhv(h,n),1)。
(25)、阶段强势股
 ?a:=sum(if(date-n=0,indexc,0),0);
b:=sum(if(date-n1=0,indexc,0)0);
e:=sum(if(date-n=0,c,0),0);
f:=sum(if(date-n1=0,c,0),0);
((f-e)/e)>((b-a)/a);
注:该公式求的是n日-n1日之间涨幅高于大盘的股票。n、n1参数的表达格式为yymmdd,注意在2000年前的表达为年份的后两位,例如1999年为99,从2000年开始以100依次向后累加,例如2001年9月14日为1010914,indexc函数表示同期大盘的收盘价,该函数对分笔成交分析周期无效。
(26)、阶段弱势股
 ?a:=sum(if(date=n,indexc,0),0);
b:=sum(if(date=n1,indexc,0)0);
e:=sum(if(date=n,c,0),0);
f:=sum(if(date=n1,c,0),0);
((f-e)/e)<((b-a)/a);
注:该公式求的是n日-n1日之间涨幅低于大盘的股票。n、n1参数的表达格式为yymmdd,注意在2000年前的表达为年份的后两位,例如1999年为99,从2000年开始以100依次向后累加,例如2001年9月14日为1010914,indexc函数表示同期大盘的收盘价,该函数对分笔成交分析周期无效。
(27)、大盘同步
   count((c>o?and?indexc>indexo)?or?(c<>m/100;
注:含义为n周期中与大盘走势相同(同收阴线或同收阳线)的例超过m%。此处的o不是数字的零,而是开盘价open的首写字母o。
(28)、n日内强势股
a:=(c-ref(o,n))/ref(o,n);
b:=(indexc-ref(indexo,n))/ref(indexo,n);
a>b?and?a/b>=m;
注:n日内个股涨幅大于等于大盘涨幅的m倍。
四、形态特征选股公式的编制
(1)、均线多头排列
 ?a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1>a2?and?a2>a3?and?a3>a4,3)=3?and?isup;
注:n1、n2、n3、n4j日均线呈多头排列,isup也可以用close>open表示。
(2)、均线空头排列
 ?a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1<><><>
注:n1、n2、n3、n4j日均线呈空头排列,isup也可以用close<>
(3)、早晨之星
   ref(close,2)/ref(open,2<0.95?and?ref(open,1)1.05?and?close>ref(close,2);
注:早晨之星,这种形态和叫法自然是后市向好,为买进信号。早晨之星由三根K线组成,其顺序是:第一天在下跌过程中已形成一根阴线:
   ref(close,2)/ref(open,2<0.95
第二天呈裂口下跌,K线实体较短,构成星的主体部分,阴线或阳线均可,有无上下影线均不重要。
   ref(open,1)
   关键是第三根K线必须是阳线,且其长度至少要升至第一根阴线实体(如果能够“包容”第一根阴线则最好不过了)
   close/open>1.05?and?close>ref(close,2)
(4)、强势整理
a1:=abs(close-open)/open<0.015;
a2:=count(a,m)=m;
a3:=ref(o,m)1+n/100;
a2?and?a3;
注:一根实体超过n的长阳,后面跟m个K线实体不超过1.5%的K线。
(5)、高开大阴线
   open>close?and?open/ref(c,1)>=1+m/100?and?close/open<=1-n/100;
注:跳空高开m%,当日股价较开盘价跌幅大于n。股价经过一段持续攀升之后,某一日突然跳高开盘:
   open/ref(c,1)>=1+m/100
   后股价一路下行,尾市以接近最低点收市:
   close/open<=1-n/100
   此信号出现,往往意味着股价已形成短期头部,应注意回避风险。
(6)、低开大阳线
   open=1+n/100;
注:跳空低开m%,当日股价较开盘价涨幅大于n,其他描述请参见(5)。
(7)、黄昏之星
   ref(close,2)/ref(open,2)>1.03?and?ref(open,1)>ref(close,2)?and?abs(ref(open,1)-ref(close,1)/ref(close,1)<0.02?and?close/open<0.97?and?close<>
注:黄昏之星表示股价回落,是卖出信号,应伺机抛货。幕星同样由三根K线组成,其形态和晨星正好相反:
   第一天股价继续上升,拉出一根阳线:
   ref(close,2)/ref(open,2)>1.03
   第二天波动较小,形成一根小阳线或小阴线,构成星的主体部分:
   ref(open,1)>ref(close,2)?and?abs(ref(open,1)-ref(close,1)/ref(close,1)<0.02
   第三天形成一根包容第二天并延伸至第一天阳线实体:
   close/open<0.97?and?close<>
(8)、跳空缺口
   highref(high,1);
注:从内容上看,分别是向下跳空缺口和向上跳空缺口。
(9)、均线金*
 ?a;=ma(c,5);
b:=ma(c,10);
cross(a,b);
注:前二句是5、10日均线,cross是交*函数,cross(a,b)表示5日均线与10日均线金*。
(10)、均线死*
 ?a;=ma(c,5);
b:=ma(c,10);
cross(b,a);
注:前二句是5、10日均线,cross是交*函数,cross(b,a)表示5日均线与10日均线死*。
(11)、均线粘合
ma1:=ma(c,5);
ma2:=ma(c,10),
ma3:=ma(c,20);
 ?p1:=abs(ma1-ma2)+abs(ma2-ma3);
p1/cref(ma1,1)?and?ma2>ref(ma2,1);
注:前三句是三根均线,p1是第一根均线减第二根均线差的绝对值与第二根均线减第三根均线差的绝对值之和,最后一句是p1与收盘价的比值小于一定比率m%(一般该比率为2%以下,同时前二均线今日比昨日上翘。

编写公式时常用的语句、通式
一、提供以下常用语句,以方便朋友们编写公式时参考使用:
1)今收盘对于N日内最低收盘价的涨幅(%)(c-llv(c,n))v(c,n)*100;
2)今收盘价对于N日最高收盘价的跌幅(%)(HHV(C,N)-C)/HHV(C,N)*100;
3)股价在过去N日内运行空间的相对位置?(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;
4)股价上方N1%至N2%处的筹码(%)
aa:=winner(c+c*n2/100)*100;
bb:=winner(c+c*n1/100)*100;
aa-bb
5)股价下方N1%至N2%处的筹码(%)
(winner(c-c*n1/100)-winner(c-c*n2/100))*100;
6)收盘价N%处的套牢盘?100-(winner(c*N/100))*100;
7)收盘价N%处的获利盘?winner(c*N/100)*100;
8)下影线?(MIN(O,C)-L)/L*100;
9)上影线?(h-max(o,c))/max(o,c)*100;
10)本周期的涨跌幅?(c-ref(c,1))/ref(c,1)*100;
11)振幅?(h-l)/l*100;
12)均线金*(M.N为均线周期)?cross(ma(c,m),ma(c,n))
13)均线多头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1>a2?and?a2>a3?and?a3>a4,3);
14)?均线空头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1<><><>
15)N日均线向下
aa:=ma(c,n);
bb:=ref(aa,2);
aa<>
16)向前N日至M日出现过均线死*(P1<>
aa:=ma(c,p1);
bb:=ma(c,p2);
cc:=ref(cross(bb,aa),n);
count(cc,m);
17)今日成交量大于N日以来的均量?VOL>MA(VOL,N);
18)低位密集
A1:=COST(85);
A2:=COST(15);
A3:=A1-A2;
A4:=(A1+A2)/2;
A5:=A3/A4*100<10;
B1:=HHV(H,120);
B2:=LLV(L,120);
B3:=B1-B2;
B4:=(A4-B2)
A5?AND?B4;
19)换手率?VOL/CAPITAL*100;
20)N日盈亏
V1:=VOL/SUM(VOL,N);
V2:=DMA(CLOSE,V1);
V3:?(CLOSE-V2)/V2*100;
21)强势整理
{参数M、N分别代表周期和幅度?m:1?20?2?n:1?20?5}
a1:=abs(close-open)/open<0.015;
a2:=count(a1,m)=m;
a3:=ref(o,m)<>
ref(close,m)/ref(close,m+1)>1+n/100;
a2?and?a3
22)高开大阴
{参数m,n分别代表幅度?m:1?10?4?n:1?20?5}
OPEN>CLOSE?AND?OPEN/REF(C,1)?>=?1+M/100?AND?CLOSE/OPEN<=1-N/100
23)低开大阳线
{参数m,n分别代表幅度?m:1?10?4?n:1?20?7}
OPEN=1+N/100
二、编写公式时常用的通式(这是在网上摘录的,仅供参考)
常用的通式:
{设A,B,R为三条曲线;N,M等为参数。如:A:ma(c,N)?;?B:=ma(c,M);?R:=c/ref(c,1)-1;等。。。}
(一).曲线在N天内的平均变化率
Fa:=(A/ref(A,N)-1)/N;?Fb:=(B/ref(B,N)-1)/N;?Fr:=(R/ref(R,N)-1)/N;
(二).变动角
∮a:=atan(Fa);?  ?∮b:=atan(Fb);????? ∮r:=atan(Fr);
(三).曲线上相距N天的两点的连线的斜率
Ka:=(A-ref(A,N))/N;? ?Kb:=(B-ref(B,N))/N;?Kr:=(R-ref(R,N))/N;
(四).倾角
∠a:=atan(Ka);?  ∠b:=atan(Kb);? ?∠r:=atan(Kr);
(五).交*点
Cab:=cross(A,B);{交*}?Jab:=longcross(A,B,N);{维持?-交*}
JYa:=between(A,N,M);{介于}?FWa:=range(A,N,M);{范围}
(六).下拐点(由下向上转)
xD1:=llvbars(A,N)=M;{以N日最低点}
xD2:=ref(count(A-ref(A,1)<=0,N)=N,M)?and?count(A-ref(A,1)>0,M)=M;{以M日变化量的正负}
xD3:=ref(count(∠a-ref(∠a,1)<=0,N)=N,M)?and?∠a>0;{以当日变化角的正负}
(七).上拐点(由上向下转)
sD1:=hhvbars(A,N)=M;{以N日最低点}
sD2:=ref(count(A-ref(A,1)>=0,N)=N,M)?and?count(A-ref(A,1)<0,M)=M;{以当日变化量的正负}
sD3:=ref(count(∠a-ref(∠a,1)>=0,N)=N,M)?and?∠a<0;{以当日变化角的正负}
(八).位置(求得交*点/拐点到当前的周期)
Wz1:=barslast(Cab);{第一(交*)点的位置}
Wz2:=ref(Wz1,Wz1+1)+Wz1+2;{第二(交*)点的位置}
Wz3:=ref(Wz1,Wz2+1)+Wz2+2;{第三(交*)点的位置}
Wz4:=ref(Wz1,Wz3+1)+Wz3+2;{第四(交*)点的位置}
Wz5:=ref(Wz1,Wz4+1)+Wz4+2;{第五(交*)点的位置}
{Wzn:=ref(Wz1,Wz(n-1)+1)+Wz(n-1)+2;}
(九).曲线A叠加曲线B
F:=A/ref(A,1)-1;{A的变化率}
Js:=ref(B,barscount(c));{叠加位置(初始)}
DJ:(sum(F,0)+1)*Js;{叠加曲线(初始位置)}
Jd:=ref(B,barslast(条件));{叠加位置(定点)}
Dj:=(sum(F,0)+1)*Jd;{叠加曲线(预定位置)}


{取大盘判断条件}
xma1:=MA(INDEXC,5);xma2:=MA(INDEXC,10);
xtj1:=CROSS(xma1,xma2)?or?xma1>xma2;
xtj2:=CROSS(xma2,xma1)?or?xma1<>
{画符合条件的背景}
FILLRGN(xtj1,SYSPARAM(5),SYSPARAM(4)),ColorDB3FCA;
FILLRGN(xtj2,SYSPARAM(5),SYSPARAM(4)),Color528608;
{画个股?K?线图}
ktj:=(CLOSE>OPEN?or?CLOSE=OPEN?and?CLOSE>REF(CLOSE,1));
STICKLINE(ktj,HIGH,LOW,0.1,1),colorred;
STICKLINE(ktj,CLOSE,OPEN,7,1),colorred;
STICKLINE(NOT(ktj),HIGH,LOW,0.1,0),colorcyan;
STICKLINE(NOT(ktj),CLOSE,OPEN,7,0),colorcyan;
{画个股均线}
ma5:MA(CLOSE,5);
ma10:MA(CLOSE,10);
ma20:MA(CLOSE,20);
ma30:MA(CLOSE,30);
别名:?画区间彩带
所属类别:?绘图函数?参数数量:?3

绘制ag改路单|注册区间彩带。
用法:
FILLRGN(COND,PRICE1,PRICE2),当COND条件满足时,以COLOR填充PRICE1和PRICE2的区间
例如:FILLRGN(MA1>MA2,?MA1,MA2),colorred?表示MA1>MA2时以红色填充MA1和MA2之间的区域。
----------------------------------------------------------
SYSPARAM(4)
系统参数:主图可见K线最高价
注意:该函数仅K线图形分析且打开十字光标时有效,否则返回值不确定

SYSPARAM(5)
系统参数:主图可见K线最低价
注意:该函数仅K线图形分析且打开十字光标时有效,否则返回值不确定
在这个例子中,是以大盘的?MA?ag改路单|注册来判断,具体条件可自己加入
将SYSPARAM(4),SYSPARAM(5)替换为0,10000效果更好,不用激活光标


另外:用?ZIG?函数判断大盘趋势来看个股{取大盘判断条件}
xtj:=ZIG(MA(INDEXC,5),10);
{画符合条件的背景}
FILLRGN(xtj>=ref(xtj,1),SYSPARAM(5),SYSPARAM(4)),ColorDB3FCA;
FILLRGN(xtj<>
{画个股?K?线图}
ktj:=(CLOSE>OPEN?or?CLOSE=OPEN?and?CLOSE>REF(CLOSE,1));
STICKLINE(ktj,HIGH,LOW,0.1,1),colorred;
STICKLINE(ktj,CLOSE,OPEN,7,1),colorred;
STICKLINE(NOT(ktj),HIGH,LOW,0.1,0),colorcyan;
STICKLINE(NOT(ktj),CLOSE,OPEN,7,0),colorcyan;
{画个股均线}
ma5:MA(CLOSE,5);
ma10:MA(CLOSE,10);
ma20:MA(CLOSE,20);
ma30:MA(CLOSE,30);



1.

怎样编制全市场平均价格公式

现在的指数不能说明市场真实平均价格,怎样写才准确呢?

沪股均价:"1A0002$AMOUNT"/"1A0002$VOL"/100;
深股均价:"399107$AMOUNT"/"399107$VOL"/100;
均价:("1A0002$AMOUNT"+"399107$AMOUNT")/("1A0002$VOL"+"399107$VOL")/100;

2.
用股价选股

input:年(2004),月(8),日(31),最小价格(1),最大价格(2);
n:=DATEDIFF(((年-1900)*10000+月*100+日),DATE);//计算输入日期和现在日期周期
tj:REF(CLOSE,n)>最小价格?and?REF(CLOSE,n)<>

3.
1,股价突破60日均线的选股公式,
2,和怎么选出一段时间以来的涨停板个股公式
1
cross(c,ma(c,60));
2
f:=ref(c,1)*1.1-c<0.01;
count(f,n)>0;//N天内出现过涨停

4.
股价横盘,MACD金叉,然后股价创新底,MACD没死叉。
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=0.04
AND?c"macd.dea";

5.
过滤一个条件成立的信号

过滤:=(EMA(C,60)>EMA(C,30))>(EMA(C,60)>EMA(C,30)*1.05);

我需要这个信号以外成立的信号
过滤:=(EMA(C,60)>EMA(C,30))>(EMA(C,60)>EMA(C,30)*1.05);
not(过滤)
***
IF(过滤,0,1);

6.
收盘价在20日均线之上,收盘价连升二天。
f:=c/ref(c,1);
count(c>ma(c,20)?and?f>1,2)=2;

7.
求最大值?

在飞狐中如何求以下四个代数式中的最大值
a-b,b-c,a-c,d-c
MAX(A,B)只能返回A和B中的较大值?
MAX(MAX(A,B),MAX(C,D));

8.

请问这两句应该如何写(副图)?
①当A线上穿B线时,在A、B两线交叉点画一条绿色竖线,
②当A线下穿B线时,在A、B两线交叉点画一条红色竖线。
大家共同提高,感谢!!
VERTLINE(cross(a,b)),colorgreen;
vertiline(cross(b,a)),colorred;

9.
求教:飞狐公式有一?ISLASTBAR怎么换成分析家的?
L2:=LD?OR?BARSTATUS=2?OR?BARSCOUNT(CLOSE)=1;

BARSTATUS=2


仅供参考
用REF(C,1)代替看看!两者有相同的地方!这个ag改路单|注册也引含着最后一个周期!
C代表条件!条件成立时,上一周期的位置!

10.
求各位高手写一个选股公式!

N天,N日均线,以N角度向上或向下运行的均线。(分析家)

atan((ma(c,n)-ref(ma(c,n),N))/N);?//值为正向上,值为负向下

11.
K线中“低点不断抬高”和“低点不断降低”的ag改路单|注册如何编??

l>ref(l,1)?and?REF(L,1)>ref(l,2)?and?REF(L,2)>ref(L,N);;{N,5,1,999}
“低点不断抬高”
反之<>

12.
符号编公式用

【】〓☆★○●◎◇◆□■△▲ⅠⅡⅢⅣⅤⅥⅦⅧⅨⅩ→←↑↓^§∧∨∪∩∈∞∝⊥∽√┣┫┻╋┼αβδωΩφΦΨΠ┳

13.
当收盘价收在7天平均线上,K线都为阳线(红色),收盘价收在7天平均线下,K线都为阴线(录色),在主图怎样写?
stickline(c>=ma(c,7),c,o,7,0),colorred;
stickline(c>=ma(c,7),h,l,1,0),colorred;
stickline(c<>
stickline(c<>

14.
20日内次高点
AA:=HHVBARS(C,20);
C=MAX(HHV(C,AA),REF(HHV(C,19-AA),AA+1));

15.
要选出收市价离125天均线不远,
ABS(C-MA6)/MA6<=0.01

16.
选股时去除ST和*ST


STRNCMP(STKNAME,?'ST',?2)=0?and?STRNCMP(STKNAME,?'*ST',?3)=0;

INBLOCK('ST')=0


17.
在条件选股中去除ST、PT股(分析家与飞狐通用)


J1:=STRCMP(LowerSTR(STRLeft(STKName,2)),'st')=0;
J2:=STRCMP(LowerSTR(STRLeft(STKName,2)),'pt')=0;
J3:=STRCMP(LowerSTR(STRLeft(STKName,3)),'*st')=0;
J4:=STRCMP(LowerSTR(STRLeft(STKName,3)),'*pt')=0;
JJ:=J1?or?J2?or?J3?or?J4;
去除PTST股:=88*(JJ=0);

18.
请大家帮个忙如何剔除150日以内的除权个股
别名:?除权发生周期数
所属类别:?行情函数?参数数量:?1

除权到现在的周期数
用法:
SPLITBARS(N),取得之前第N次除权到当前的周期数
例如:
SPLITBARS(0)=0表示当天发生除权

19.
大智慧?引入?周线?kdj?交叉?怎么引入???
{周KDJ}
周k:MA("kdj.k"(9,3,3)WEEKDAY,5),COLORWHITE;
周d:MA("kdj.d"(9,3,3)WEEKday,5),COLOR33FF99;
周金▲:DRAWTEXT(CROSS(周k,周d),周d,'▲'),COLORRED;
周死▼:DRAWTEXT(CROSS(周d,周k),周d,'▼'),COLOR00FF00;

20.
写均线MA1二次上穿MA4公式!
COUNT(CROSS(ma1,ma4),20)=2;


1.
成交量连续5天超过30天均量点
count(vol>ma(vol,30),5)=5
2.
请老师编一选股公式;要求1;日均线多头排列的情况下(5,10,30,60。。。)2:5日。10日均线高度粘合--相等或相差1-2分钱,30均线与5,10均线相差1角以下。3:日量比大于2。先大家共同提高,感谢!!!
1.ma(c,5)>ma(c,10)?and?ma(c,10)>ma(c,30)?and?ma(c,30)>ma(c,60)?and?。。。

2.abs(ma(c,5)-ma(c,10))<0.03?and?abs(ma(c,30)-max(ma(c,5),ma(c,10)))<0.1

3.DYNAINFO(17)>2


3.
威力雷达rad7日内连续上扬怎样编写?大家共同提高,感谢
V1:=(c/ref(c,1)-indexc/ref(indexc,1))*200;
RAD:=sum(v1,0);

count(rad>ref(rad,1),7)=7

威力雷达Mrad在7日内连续上扬怎样编写?大家共同提高,感谢
V1:=(c/ref(c,1)-indexc/ref(indexc,1))*200;
RAD:=sum(v1,0);

MRAD:=MA(RAD,30);

count(mrad>ref(mrad,1),7)=7

4.
请问。10日内涨幅大于10%的选股公式怎样编?
c/ref(c,10)>1.1

5.
如何编写股价在一个上涨或下跌的行情中第3次触及30日均线时发出提醒的ag改路单|注册?
M3:=MA(C,30);

N1:=BARSLAST(M3>REF(M3,1));

AA:=CROSS(C,M3);

COUNT(AA,N1)=3


6.
请问:cysag改路单|注册中数值要小于-5,怎样编写到其他ag改路单|注册中.,大家共同提高,感谢!
(C-CYC(13))/CYC(13)*100<-5


7.
当涨幅大于5%,要主图K线的实体的一半变为另一色。如何表达?
STICKLINE(c/ref(c,1)>1.05,(c+o)/2,c,10,1),coloryellow;

8.
成交量连续3天涨的公式
COUNT(VOL>REF(VOL,1),3)=3

9.
请问怎样用公式表示年线摆脱下降趋势出现向上拐头?
COUNT(MA(C,250)>REF(MA(C,250),1),3)=3

10.
股价创出新高后,又调整到30日均线附近的选股公式如何编写?

COUNT(C>=HHV(C,N),5)=1?AND?C/MA(C,30)>=1?AND?C/MA(C,30)<1.02


11.
怎么定义一阳线紧跟两阴线的函数?
ref(c,2)>ref(o,2)?and?ref(c,1)<><>


12.
60日线在过去的10天内涨跌幅度在?1%
COUNT(BETWEEN(ma(c,60),ref(ma(c,60),10)*1.01,ref(ma(c,60),10)*0.99),10)=10;


13.
RSI(周线)在70天内第二次上穿80,如何编制?
COUNT(CROSS("RSI.RSI1#WEEK",80),70)=2

14.
今天涨幅3%昨天涨幅2%前天涨幅1%的个股
(c-ref(c,1))/ref(c,1)>0.3?and?(ref(c,1)-ref(c,2))/ref(c,2)>0.2?and?(ref(c,2)-ref(c,3))/ref(c,3)>0.1

15.
破5天线,3天后又重新站上5天线的个股
cross(ref(ma(c,5),3),ref(c,3))?and?cross(c,ma(c,5))

16.
今天一阳上穿5,10,30天线个股
cross(c,ma(c,5)?and?cross(c,ma(c,10))?and?cross(c,ma(c,30))

17.
3天内5天线上穿10天线,10天线上穿20天线的个股
count(cross(ma(c,5),ma(c,10)),3)>=1?and?count(cross(ma(c,10),ma(c,20)),3)>=1

18.
日macd翻绿3内又翻红的个股。
count(cross(0,"MACD.MACD"?),3)=1?and?count(cross("MACD.MACD",0?),3)=1

19.
5天线拐头向下3天内又拐头向上的个股。
count(cross(ref(ma(c,5),1),ma(c,5)),3)=1?and?count(cross(ma(c,5),ref(ma(c,5),1)),3)=1

20.
收盘价比开盘价高出6%,当日涨幅超过6%,实体占整天振幅的80%以上
C/O>1.06?AND?C/REF(C,1)>1.06?AND?C-O>0.8*(H-L)



1)今收盘对于N日内最低收盘价的涨幅(%)(c-llv(c,n))v(c,n)*100;
2)今收盘价对于N日最高收盘价的跌幅(%)(HHV(C,N)-C)/HHV(C,N)*100;
3)股价在过去N日内运行空间的相对位置?(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;
4)股价上方N1%至N2%处的筹码(%)
aa:=winner(c+c*n2/100)*100;
bb:=winner(c+c*n1/100)*100;
aa-bb
5)股价下方N1%至N2%处的筹码(%)
(winner(c-c*n1/100)-winner(c-c*n2/100))*100;
6)收盘价N%处的套牢盘?100-(winner(c*N/100))*100;
7)收盘价N%处的获利盘?winner(c*N/100)*100;
8)下影线?(MIN(O,C)-L)/L*100;
9)上影线?(h-max(o,c))/max(o,c)*100;
10)本周期的涨跌幅?(c-ref(c,1))/ref(c,1)*100;
11)振幅?(h-l)/l*100;
12)均线金叉(M.N为均线周期)?cross(ma(c,m),ma(c,n))
13)均线多头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1>a2?and?a2>a3?and?a3>a4,3);
14)?均线空头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1<><><>
15)N日均线向下
aa:=ma(c,n);
bb:=ref(aa,2);
aa<>
16)向前N日至M日出现过均线死叉(P1<>
aa:=ma(c,p1);
bb:=ma(c,p2);
cc:=ref(cross(bb,aa),n);
count(cc,m);
17)今日成交量大于N日以来的均量?VOL>MA(VOL,N);
18)低位密集
A1:=COST(85);
A2:=COST(15);
A3:=A1-A2;
A4:=(A1+A2)/2;
A5:=A3/A4*100<10;
B1:=HHV(H,120);
B2:=LLV(L,120);
B3:=B1-B2;
B4:=(A4-B2)
A5?AND?B4;
19)换手率?VOL/CAPITAL*100;
20)N日盈亏
V1:=VOL/SUM(VOL,N);
V2:=DMA(CLOSE,V1);
V3:?(CLOSE-V2)/V2*100;
21)强势整理
{参数M、N分别代表周期和幅度?m:1?20?2?n:1?20?5}
a1:=abs(close-open)/open<0.015;
a2:=count(a1,m)=m;
a3:=ref(o,m)<>
ref(close,m)/ref(close,m+1)>1+n/100;
a2?and?a3
22)高开大阴
{参数m,n分别代表幅度?m:1?10?4?n:1?20?5}
OPEN>CLOSE?AND?OPEN/REF(C,1)?>=?1+M/100?AND?CLOSE/OPEN<=1-N/100
23)低开大阳线
{参数m,n分别代表幅度?m:1?10?4?n:1?20?7}
OPEN=1+N/100


1间隔点:
20,colorred,pointdot,linethick2;
80,colorred,pointdot,linethick2;
50,colorred,pointdot,linethick2;
2间隔线
20,colorred,linethick2;
80,colorred,linethick2;
50,colorred,linethick2;
3信号字
DRAWTEXT(RSI1<10,RSI1,'买'),Colorlime;
DRAWTEXT(RSI1>85,RSI1,'卖'),Colorlime;
4笑哭脸
DRAWICON(VR24<25,VR24,1),ColorFF0000;
DRAWICON(VR24>350,VR24,2),ColorFF0000;
5一线提示
cross("kdj.j"(9,3,3),"kdj.d"(9,3,3))?and?"kdj.j"(9,3,3)<20,colorred
6一柱顶天
IF(VAR4=50,50,0),stick,linethick2;
7小人作怪
多头卒:Var3,LINETHICK2,?COLORf00ff0;
空头卒:Var4,LINETHICK2,?COLORYELLOW;
DRAWICON(Var9,Var9,1);
DRAWICON(Var10,Var10,2);

8小人
买入:Var1?AND?Var2,stick,linethick2,colorred;
卖出:CROSS(80,Var4),stick,linethick2,colorgreen;
drawicon(卖出,1.1,2);
drawicon(买入,1.1,1);

9粗细面条
LINETHICK2

第3,4,6和7,还有8只要把RSI或VR或Var改成所在公式参数就可用;第5cross不能改,其它的可改;9你爱把线设多粗细都行。
1方块STICKLINE
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE
卖盘:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE
qq:=买盘+卖盘;
STICKLINE(卖盘<0,0,VOL,5,1),COLORlime;
STICKLINE(买盘>0,0,买盘,5,0),COLORRED;
结果:ma(qq,5)*5,COLORRED,LINETHICK2;

VOL后面的5,1是方块大少。VOL是坐标,也就是方块所放的地方。
2?3D效果
STICKLINE(OPEN>=CLOSE?,CLOSE?,OPEN,9,0?),COLORaaaaaa;
STICKLINE(OPEN>=CLOSE?,CLOSE?,OPEN,6,0?),COLORbbbbbb;
STICKLINE(OPEN>=CLOSE?,CLOSE?,OPEN,2.4,0?),COLORcccccc;
STICKLINE(OPEN>=CLOSE?,CLOSE?,OPEN,1.1,0?),COLORdddddd;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,9,0?),COLOr6666cc;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6?,0?),COLOR7777dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4?,0?),COLOR8888ee;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.1?,0?),COLOR9999ff;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0?),COLOR1199ff;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5?,0?),COLOR1199ff;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5?,0?),COLORcccccc;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5?,0?),COLORcccccc;


3颜色
大智慧只能用浅色调,一用深绿深蓝就看不见了。所以我调了几个浅色的,够大智慧用的。
COLOR+RED;WHITE;LIME;YELLOW;aabbcc;ffaabb;abcdef;999999;C0C0C0.

4变色
变色可分3种:
1用DRAWTEXT:
ma10:ma(c,10),colorwhite;
llv(h,30),colorffcc66;
llv(l,30),coloryellow;
vhh:hhv(h,30),colorred;
vhl:hhv(l,30),color00ff00;
v1:=ma(HIGH,30)*1.15?;
v2:=ma(HIGH,3)*1.03;
v3:=ma(LOW,3)*0.97;
v4:=ma(LOW,30)*0.85;
小通道上:=ma(v2,30);
小通道下:=ma(v3,30);
A2:=小通道上-REF(小通道上,1);
A3:=小通道下-REF(小通道下,1);
K:A2>0?and?ref(A2<0,1),colorblue;
K1:A3>0?and?ref(A3<0,1),colorff00ff;
K2:c<><>
K3:c<小通道下?and?a3>0,colorffcccc;
K4:h<小通道下?and?a3>0,colorffbbff;
DRAWTEXT(A2>0?,小通道上,'°'),colorred;
DRAWTEXT(A2<0?,小通道上,'°'),color00ff00;
DRAWTEXT(A3>0?,小通道下,'°'),colorred;
DRAWTEXT(A3<0?,小通道下,'°'),color00ff00;
DRAWTEXT(A2=0?,小通道上,'°'),COLORWHITE;
DRAWTEXT(A2=0?,小通道下,'°'),COLORWHITE;
DRAWTEXT(A3=0?,小通道上,'°'),COLORWHITE;
DRAWTEXT(A3=0?,小通道下,'°'),COLORWHITE;

2用STICKLINE
AA:=WINNER(C)*100;
KA:=winner(O)*100;
高:=winner(H)*100;
低:=winner(L)*100;
庄筹线:EMA(AA*0.7,3),linethick2;
散筹线:EMA((WINNER(C*1.08)-WINNER(C*0.92))*70,3),linethick2;
stickline(AA<>
stickline(AA<>
stickline(AA>=KA,高,低,0,0),colorred;
stickline(AA>=KA,AA,KA,6,0),colorred;
stickline(庄筹线>散筹线,庄筹线,散筹线,0,0),colorwhite;

3用IF
主图公式1:
A1:=Ma(C,5);{5日移动平均线}
A2:=Ma(C,10);{10日移动平均线}
A3:=(A1+A2)/2;{5、10日移动平均线之和除2的平均线,也就是中心线}
IF?(A1>A2,A1,A3),Colorred,linethick2;{5日线大于10日且5日线交叉A3线显示粗红线}
IF?(A1>A2,A2,A3),Colorred,linethick2;{5日线大于10日且10日线交叉A3线显示粗红线}
IF?(A1<=A2,A1,A3),Color00ff00,linethick2;{5日线小于等于10日且5日线交叉A3线显示粗绿线}
IF?(A1<=A2,A2,A3),Color00ff00,linethick2;{5日线小于等于10日且10日线交叉A3线显示粗绿线}
A3,colorwhite,linethick2;{中心线显示粗白线}
这是以中心线为轴通过A1、A2这两条线与中心线的交叉来变换颜色的。
主图公式2:
MA1:=MA(CLOSE,5);{5日移动平均线}
MA2:=MA(CLOSE,10);{10日移动平均线}
MA3:=MA(CLOSE,20);{20日移动平均线}
MA4:=MA(CLOSE,30);{30日移动平均线}
MAA:=MA(CLOSE,60);{60日移动平均线}
MA5:IF(MA1<>
IF(MA1<>
MA10:if(ma2<>
if(ma2<>
MA20:if(ma3<>
if(ma3<>
MA30:if(ma4<>
if(ma4<>
MA60:if(ma4>maa,maa,maa),linethick2,colorblue;{MA4线大于MAA且MAA线交叉MAA线显示兰色粗线}
这是分别以MA4、MAA线为轴通过向上交叉和向下交叉来变换颜色的。
单条变色线
ma10:ma(c,10);
if(ma10>ref(ma10,1),ma10,0),Circledot,COLORRED,LINETHICK2;
if(ma10<>