技术支持 Support
联系方式 Contact

云ag改路单|注册公式网

淘宝:zb-mart.taobao.com

电话:18020657357

Q Q:396950280

网址:www.yzhibiao.com

搜索 Search
你的位置:首页 > 技术支持 > 公式改编

各种股票软件ag改路单|注册公式修改编辑大全

2014-10-14 11:00:59点击:

代理编写(对转)通达信 飞狐 同花顺 大智慧 文华财经 博易大师 依天财经等软件ag改路单|注册!

想要自己编ag改路单|注册ag改路单|注册或修改就参考以下大全:
参数名称:最小值,最大值,缺省值
   ? ???N:? ?? ? 1? ???10O? ? 9
  ? ?? ? M1:? ???2? ???40? ???3
  ? ?? ? M2:? ???2? ???4 0? ? 3

    RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
    K:SMA(RSV,M1,1);
    D:SMA(K,M2,1);
    J:3*K-2*D

  该ag改路单|注册绘制K、D、J两条ag改路单|注册线。RSV行是一个中间语句,计算当期收盘价与N天内最低价之差除以N内最高价与最低价之差的比值,再乘以系数100。K线为RSV的M1天移动平均线,D线为线K的M2天移动平均线,J线为K线与J线的差值。

(以下是引用‘wjwjc’版主对计算‘5日均线上升角度’的实例讲解

aa:=ma(c,5);{这是5日均线}
bb:=ref(ma(c,5),1);{这是昨日5日均线}
cc:(aa-bb)/bb>n/100;{这是5日均线增长比率,比率越大,其上长的斜率就越大}
n是参数,n%是5日均线的增长比率,因此n定5以上可能其的斜率就越大,你可试试。)

(对于时间限制的问题,我们就以‘庄家进出’ag改路单|注册来作分析了解。

Var1:=IF(YEAR>=2034 AND MONTH>=1,0,1);
{VAR1赋值:如果年份>=2034 AND 月份>=1,返回0,否则返回1}
{点评:这个语句在配合其它语句使用的情况下可起到时间限制作用}

VarC:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE
{VARC赋值:如果收盘价>昨收,返回成交量(手),否则返回(如果收盘价<昨收,返回0-成交量(手),否则返回0)的历史累和>
{点评:在这句用到了VAR1,当VAR1符合条件即:年份>=2034 和 月份>=1时,则VAR1=0,这样以后计算出来的结果全是0,这时该ag改路单|注册便毫无意义了,起到了时间限制的作用。}

分界线: EMA(VarC,26)*Var1, LINETHICK2, COLORf0f000;
{输出分界线: VARC的26日异同移动平均*VAR1, LINETHICK2, COLORF0F000}

庄家线1: EMA(VarC,1)*Var1, COLORRED;
{输出庄家线1: VARC的1日异同移动平均*VAR1, 画红色}

庄家线2: EMA(VarC,6)*Var1, COLORYELLOW;
{输出庄家线2: VARC的6日异同移动平均*VAR1, 画黄色}

庄家线3: EMA(VarC,12)*Var1, COLOR00ff00 ;
{输出庄家线3: VARC的12日异同移动平均*VAR1, COLOR00FF00 })

颜色代码
如:colorred{红}
colormagenta(COLORf00ff0){品红} coloryellow{黄} colorgray{灰} colorffff00{兰} colorblue{青} colorwhite{白} colorgreen{绿} colorbrown{棕}
linethick{0--7ag改路单|注册线粗细} linethick{同时显示柱状线和ag改路单|注册线}
circledot{空心园点} pointdot{小点} pointdot,linethick2{实心方点}
crossdot{X点状线} cmcledot{0点状线} stick{显示} colorstick{显示}
linestick{显示} 希望各位ag改路单|注册爱好者自己动手进行配色修改,这样才会记得
牢,学得透,不断探索,不断前进。一花开放不是春,万紫千红春满园。
走势形态特征ag改路单|注册:为了满足大家选股的需要,这里主要介绍股票走势特征、形态特征ag改路单|注册的编制。

走势形态特征ag改路单|注册编制的基础。
(1)放量、缩量(成交量函数为VOL)
A、放量
? ?a.今天成交量较昨天增加了1倍,表示如下:
   VOL/REF(VOL,1)>2
? ?b.今天成交量较10个交易日平均成交量放大了1倍,表示如下:
a:=ma(vol,10);
Vol/a>2
? ?或者直接用如下ag改路单|注册表示:
vol/ma(vol,10)>2;
? ?c.今日的5日均量较10个交易日平均成交量放大了1倍,表示如下:
   a:=ma(vol,10);
? ?b:=ma(vol,5);
? ?b/a>2;
? ?d.今日的成交量超过了整个流通盘的5%,表示如下:
   vol/capital>0.05;其中capital代表流通盘。
B、缩量
  a.今日成交量较昨日减少了一半,表示如下:
? ?vol/ref(vol,1)<0.5;
? ?b.今日成交量较10个交易日平均成交量减少一倍,表示如下:
   a:=ma(vol,10);
? ?vol/a<2;
? ?或者直接用如下ag改路单|注册表示:
   vol/ma(vol,10)<2;
? ?c.今日的5日均量较10个交易日平均成交量减少1倍,表示如下:
? ?a:=ma(vol,10);
? ?b:=ref(a,5);
? ?a/b<2;
? ?d.今日的成交量低于了整个流通盘的5%,表示如下:
? ?vol/capital<0.05;

(2)上涨、下跌
上涨
今天的涨幅达到5%以上,表示如下:
close>ref(close,1)>1.05;
5日均价连续上涨,表示如下:
a:=ma(close,5);
b:=ref(a,1);
b;
下跌
今天的跌幅达到5%以上,表示如下:
close/ref(close,1)<0.95;
5日均价连续下跌,表示如下:
a:=ma(close,5);
b:=ref(a,1);
a<>

(3)K线的描述
阳线
close>open;
阴线
close<>
高开
open>ref(close,1);
低开
open<>
跳空高开(high为最高价)
open>ref(high,1);
跳空低开(low为最低价)
open<>

走势特征选股ag改路单|注册的编制
(1)n日内创新高
   hhv(high,n)=hhv(high,0) and barscount(c)>=n;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。Hhv(x,n),求n周期内x最高值,n=0则从第一个有效值开始;barscount(x),将当前位置到n周期前的数值设为1,若x非0,则将当前位置到n周期前的数值设为1。
(2)n日内创新低
   llv(low,n)=llv(low,0) and barscount(close)>=n;
注n为ag改路单|注册参数,可在参数设定范围内设定参数范围。Llv(x,n),求n周期内x最低值,n=0则从第一个有效值开始;barscount(x)第一个有效数据到当前的天数,例如,barscount(close)以于日线数据取得上市以来总交易日数。
(3)n日内阴线多于阳线
   count(open>close,n)/n<0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等 ,达到确定阴线占全部K线个数的比例)。
(4)n日内阳线多于阴线
   count(open0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等 ,达到确定阳线占全部K线个数的比例)。
(5)n日内上涨多于下跌(第二天开盘高于前一天收盘)
count(c>ref(c,1),n)/n>0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等 ,达到确定其中比例)。
(6)n日内上涨少于下跌(第二天开盘低于前一天收盘)
   count(c>ref(c,1),n)/n<0.5;
注:n为ag改路单|注册参数,可在参数设定范围内设定参数范围。同时可以自由编辑里面的数值(如0.5等 ,达到确定其中比例)。
(7)连续n日收阳线
   up:=close>open;
count(up,n)=n;
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。n为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(8)连续n日内收阴线
   up:=close<>
count(up,n)=n;
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。N为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(9)连续n天上涨
   count(close>ref(close,1),n)=n;
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。N为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(10)连续n天下跌
   count(c<>
注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。N为ag改路单|注册参数,可在参数设定范围内设定参数范围。
(11)首次创新高
   barssince(c>hhv(if(barscount(c)=1,high,0),0))+1=1;
注:barscount(x),若x非0,则将当前位置到n周期前的数值设为1。
(12)创历史新高
   hhv(close,0)=close;
注:hhv(x,n),求n周期内x最高值,n=0则从第一个有效值开始。
(13)创历史新低
   llv(close,0)=close;
注:llv(x,n),求n周期内x最小值,n=0则从第一个有效值开始。
(14)单日放量
   a:=ref(ma(vol,5),1);
vol/a>n and vol/capital*100>m;
注:n为ag改路单|注册参数,代表今日成交量和前一日的5日均量的比值,可在参数设定范围内设定参数范围。
(15)阶段缩量
   sum(vol,n1)/capital<=n2;
注:n1为要统计的阶段时间,n2为缩量比例,可在参数设定范围内设定参数范围。
(16)阶段放量
   sum(vol,n1)/capital>=n2;
注:n1为要统计的阶段时间,n2为y放量比例,可在参数设定范围内设定参数范围。
(17)持续放量
   a:=vol>ref(vol,1);
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日放大,n为要统计的阶段时间,可在参数设定范围内设定参数范围。
(18)持续缩量
   a:=vol<>
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日缩小,n为要统计的阶段时间,可在参数设定范围内设定参数范围。
(19)间隔放量
   a:=ma(vol,5);
barscount(c)>=n and hhv(a,n)n2*a,n)>n3;
注:a.barscount(x)第一个有效数据到当前的天数。Barscount(c)对于日线数据取得上市以来总交易日数。
b.完整含义:n日内五日均量的最大值小于最小值的n1倍,成交量大于等于五日均量的n2倍的情况发生的次数多于n3次。
(20)放量上攻
a:=(c-ref(c,1))/ref(c,1)>=(n/100);
sum(vol,n1)/capital>=(n2/100) and count(vol>ref(vol,1),n3 )=n3 and count(a,n3)=n3;
完整含义:每日股价涨幅均大于n%,n1日内累计换手率大于n2%,并且成交量连续在n3日内放大。
(21)温和放量上攻
   股价小幅上扬
a1:=close/ref(close,1);
a2:=a1>1 and a1<1.03;
成交量小幅上扬
   b1:=vol/ref(vol,1);
b2:=b1>1 and b1<2;
c1:=ma(vol,n)/capital<0.05;
count(a2 and b2,n)/n>0.6 and c1;
完整ag改路单|注册为:
   a1:=close/ref(close,1);
a2:=a1>1 and a1<1.03;
b1:=vol/ref(vol,1);
b2:=b1>1 and b1<2;
c1:=ma(vol,n)/capital<0.05;
count(a2 and b2,n)/n>0.6 and c1;
注:ag改路单|注册分为股价小幅上扬和成交量小幅上扬两个部分,请在ag改路单|注册编写时注意其结构。
(22)突然放量
   vol>ref(hhv(vol,n),1*m;
注:当前成交量高于n个周期中最大成交量的m倍。
(23)平台整理
   count(close,0)>n and (hhv(close,n)-llv(close,n))/llv(close,n)<=(n1/100);
注:count(close,0)>n为平台整理n个周期的设定。(hhv(close,n)-llv(close,n))/llv(close,n)<=(n1/100)为平台整理幅度n1%的设定。
(24)突破长期盘整
ref(((hhv(h,n)-llv(l,n))/llv(l,n))/llv(l,n)),1)<=(n1/100) and c>=ref(hhv(h,n),1) and barscount(c)>n;
注:前n日在上下n1%的幅度内整理:ref(((hhv(h,n)-llv(l,n))/llv(l,n))/llv(l,n)),1)<=(n1/100);
今日突破:c>=ref(hhv(h,n),1)。
(25)阶段强势股
   a:=sum(if(date-n=0,indexc,0),0);
b:=sum(if(date-n1=0,indexc,0)0);
e:=sum(if(date-n=0,c,0),0);
f:=sum(if(date-n1=0,c,0),0);
((f-e)/e)>((b-a)/a);
注:该ag改路单|注册求的是n日-n1日之间涨幅高于大盘的股票。n、n1参数的表达格式为yymmdd,注意在2000年前的表达为年份的后两位,例如1999年为99,从2000年开始以100依次向后累加,例如2001年9月14日为1010914,indexc函数表示同期大盘的收盘价,该函数对分笔成交分析周期无效。
(26)阶段弱势股
   a:=sum(if(date=n,indexc,0),0);
b:=sum(if(date=n1,indexc,0)0);
e:=sum(if(date=n,c,0),0);
f:=sum(if(date=n1,c,0),0);
((f-e)/e)<((b-a)/a);
注:该ag改路单|注册求的是n日-n1日之间涨幅低于大盘的股票。n、n1参数的表达格式为yymmdd,注意在2000年前的表达为年份的后两位,例如1999年为99,从2000年开始以100依次向后累加,例如2001年9月14日为1010914,indexc函数表示同期大盘的收盘价,该函数对分笔成交分析周期无效。
(27)大盘同步
   count((c>o and indexc>indexo) or (cm/100;
注:含义为n周期中与大盘走势相同(同收阴线或同收阳线)的例超过m%。此处的o不是数字的零,而是开盘价open的首写字母o。
(28)、n日内强势股
a:=(c-ref(o,n))/ref(o,n);
b:=(indexc-ref(indexo,n))/ref(indexo,n);
a>b and a/b>=m;
注:n日内个股涨幅大于等于大盘涨幅的m倍。
形态特征选股ag改路单|注册的编制
(1)均线多头排列
   a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1>a2 and a2>a3 and a3>a4,3)=3 and isup;
注:n1、n2、n3、n4j日均线呈多头排列,isup也可以用close>open表示。
(2)均线空头排列
   a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1
注:n1、n2、n3、n4j日均线呈空头排列,isup也可以用close<>
(3)早晨之星
   ref(close,2)/ref(open,2<0.95 and ref(open,1)1.05 and close>ref(close,2);
注:早晨之星,这种形态和叫法自然是后市向好,为买进信号。早晨之星由三根K线组成,其顺序是:
   第一天在下跌过程中已形成一根阴线:
   ref(close,2)/ref(open,2<0.95
第二天呈裂口下跌,K线实体较短,构成星的主体部分,阴线或阳线均可,有无上下影线均不重要。
   ref(open,1)
   关键是第三根K线必须是阳线,且其长度至少要升至第一根阴线实体(如果能够“包容”第一根阴线则最好不过了)
   close/open>1.05 and close>ref(close,2)
(4)强势整理
a1:=abs(close-open)/open<0.015;
a2:=count(a,m)=m;
a3:=ref(o,m)1+n/100;
a2 and a3;
注:一根实体超过n的长阳,后面跟m个K线实体不超过1.5%的K线。
(5)高开大阴线
   open>close and open/ref(c,1)>=1+m/100 and close/open<=1-n/100;
注:跳空高开m%,当日股价较开盘价跌幅大于n。股价经过一段持续攀升之后,某一日突然跳高开盘:
   open/ref(c,1)>=1+m/100
   后股价一路下行,尾市以接近最低点收市:
   close/open<=1-n/100
   此信号出现,往往意味着股价已形成短期头部,应注意回避风险。
(6)低开大阳线
   open=1+n/100;
注:跳空低开m%,当日股价较开盘价涨幅大于n,其他描述请参见(5)。
(7)黄昏之星
   ref(close,2)/ref(open,2)>1.03 and ref(open,1)>ref(close,2) and abs(ref(open,1)-ref(close,1)/ref(close,1)<0.02 and close/open<0.97 and close<>
注:黄昏之星表示股价回落,是卖出信号,应伺机抛货。幕星同样由三根K线组成,其形态和晨星正好相反:
   第一天股价继续上升,拉出一根阳线:
   ref(close,2)/ref(open,2)>1.03
   第二天波动较小,形成一根小阳线或小阴线,构成星的主体部分:
   ref(open,1)>ref(close,2) and abs(ref(open,1)-ref(close,1)/ref(close,1)<0.02
   第三天形成一根包容第二天并延伸至第一天阳线实体:
   close/open<0.97 and close<>
(8)跳空缺口
   highref(high,1);
注:从内容上看,分别是向下跳空缺口和向上跳空缺口。
(9)均线金叉
   a;=ma(c,5);
b:=ma(c,10);
cross(a,b);
注:前二句是5、10日均线,cross是交叉函数,cross(a,b)表示5日均线与10日均线金叉。
(10)均线死叉
   a;=ma(c,5);
b:=ma(c,10);
cross(b,a);
注:前二句是5、10日均线,cross是交叉函数,cross(b,a)表示5日均线与10日均线死叉。
(11)均线粘合
ma1:=ma(c,5);
ma2:=ma(c,10),
ma3:=ma(c,20);
   p1:=abs(ma1-ma2)+abs(ma2-ma3);
p1/cref(ma1,1) and ma2>ref(ma2,1);
注:前三句是三根均线,p1是第一根均线减第二根均线差的绝对值与第二根均线减第三根均线差的绝对值之和,最后一句是p1与收盘价的比值小于一定比率m%(一般该比率为2%以下,同时前二均线今日比昨日上翘。?
3.1 ag改路单|注册ag改路单|注册:均线通道
新建ag改路单|注册“均线通道”(JXTD)
1.使用快捷键Ctrl+F打开“ag改路单|注册**器”。
2.点击“新建”按钮,打开“ag改路单|注册编辑器”
3.填写ag改路单|注册项
“ag改路单|注册名称”---JXTD,
“ag改路单|注册描述”---“均线通道”
参数 (最小值)(最大值)(缺省值)
#N: 1 100 26
--------------------------------------------------
VAR1:=MA(CLOSE,N);{对“VAR1”赋值}
VAR2:=MA(CLOSE,2*N);{对“VAR2”赋值}
VAR3:=MA(CLOSE,3*N);{对“VAR3”赋值}
VAR4:=MA(CLOSE,4*N);{对“VAR4”赋值}
VAR5:=MA((VAR1+VAR2+VAR3+VAR4)/4,5);{一条多条均线的平均线}
上轨:VAR5*1.08;{在均线“VAR5”上加上8%的幅度变成“上轨”}
下轨:VAR5*0.92; {在均线“VAR5”上减去8%的幅度变成“下轨”}
----------------------------------------------------
4.ag改路单|注册类型:选“路径型”,还有大势型、超买超卖型、趋势型、能量型等如图
5.画线方法:副图、主图叠加、副图叠加线、副图叠加美国线四种;选中“主图叠加型”,副图是K线图下面的区域;
6.密码保护:010101
7.参数设置:#N:最小值为1,最大值为100,缺省值(默认)为26;
8.坐标线位置:在非“主图叠加”中,此编辑框处可写状态;输出线为副图中深红色横线显示,是副图坐标线;
9.额外Y轴分界:是ag改路单|注册敏感数值输出线,在副图中显示为白色;
10.引入ag改路单|注册ag改路单|注册:在引入原ag改路单|注册的基础上进行编辑;
11.插入函数:左上为函数类别,右上为函数表,下区为函数解释区及用法举例;
12.ag改路单|注册编辑区:
〖{ }〗是解释,不输出,为了提示自己和别人,便于看懂ag改路单|注册;
〖:=〗赋值符,意为“相当于”;
〖:〗输出符,它前面的名称为输出名称,可以在副图中看到,它后面的为ag改路单|注册定义;
〖;〗分段符,表示一段完成;
〖,〗分节符;
〖()〗括号中为ag改路单|注册体。
13.测试ag改路单|注册:测试通过则自动保存;测试不能通过,则在翻译区提示错误所在。
14.用法注释:自编ag改路单|注册使用说明。
15.在K线图上,直接敲字母键“JXTD”调出自编的ag改路单|注册“均线通道”,查看结果;
16.修改ag改路单|注册:左键选中ag改路单|注册线后,点击右键,在弹出的对话框中,选中“修改ag改路单|注册”项,直接调出《ag改路单|注册编辑器》修改ag改路单|注册。如果左键选ag改路单|注册线不便,直接用右键选参数数值,也可调出ag改路单|注册编辑器。
17.鼠标动态提示:将鼠标放在函数上,等一会系统自动出现提示框,方便函数学习和应用,如图:

3.2 选股ag改路单|注册:均线通道

改ag改路单|注册“均线通道”(JXTD)为选股ag改路单|注册“均线通道”
1. 〖Ctrl〗+〖F〗打开“ag改路单|注册**器”;
2. 点击“条件选股ag改路单|注册”选项;
3. 点击“新建”按钮,打开“条件选股ag改路单|注册编辑器”;
4. 点击“引入ag改路单|注册ag改路单|注册”按钮,选最后一项“均线通道”,确定;
5.修改输出:ag改路单|注册输出项改为赋值项;即将〖:〗符改为〖:=〗符;
6.新建输出项:选股:CLOSE<>
7.测试ag改路单|注册通过;
8. 〖Ctrl〗+〖T〗打开条件选股ag改路单|注册“均线通道”,进入ag改路单|注册选股操作程序;

3.3 五彩K线ag改路单|注册:均线通道
改ag改路单|注册“均线通道”(JXTD)为五彩K线ag改路单|注册“均线通道”
1. 〖Ctrl〗+〖F〗打开“ag改路单|注册**器”;
2. 点击“五彩K线ag改路单|注册”选项;
3. 点击“新建”按钮,打开“K线指示ag改路单|注册编辑器”;
4. 点击“引入ag改路单|注册ag改路单|注册”按钮,选“均线通道”确定;

五彩K线ag改路单|注册
ag改路单|注册名:JXTD
ag改路单|注册描述:均线通道
参数 (最小值)(最大值)(缺省值)
#N: 1 100 26
--------------------------------------------------
VAR1:=MA(CLOSE,N);{对“VAR1”赋值}
VAR2:=MA(CLOSE,2*N);{对“VAR2”赋值}
VAR3:=MA(CLOSE,3*N);{对“VAR3”赋值}
VAR4:=MA(CLOSE,4*N);{对“VAR4”赋值}
VAR5:=MA((VAR1+VAR2+VAR3+VAR4)/4,5);{一条多条均线的平均线}
上轨:=VAR5*1.08;{在均线“VAR5”上加上8%的幅度变成“上轨”}
下轨:=VAR5*0.92; {在均线“VAR5”上减去8%的幅度变成“下轨”}
CLOSE<下轨,colorred;>
CLOSE>上轨,COLORYELLOW; {高于上轨提示卖出黄色}
HIGH>上轨*1.06,COLORBLUE;{高于上轨6%提示清仓蓝色}
LOW<下轨*0.94,>
--------------------------------------------------
5.测试通过,退出;
6.〖Ctrl〗+〖K〗,打开“五彩K线指示”---“均线通道”;
7.查看效果,不满意就修改参数一直到满意为止;

3.4 交易系统ag改路单|注册
改ag改路单|注册“均线通道”(JXTD)为交易系统ag改路单|注册“均线通道”
1. 〖Ctrl〗+〖F〗打开“ag改路单|注册**器”;
2. 点击“交易系统ag改路单|注册”选项;
3. 点击“新建”按钮,打开“交易系统ag改路单|注册编辑器”;
4. 点击“引入ag改路单|注册ag改路单|注册”按钮,选“均线通道”确定;
ag改路单|注册名:JXTD
ag改路单|注册描述:均线通道
参数 (最小值)(最大值)(缺省值)
#N: 1 100 26
--------------------------------------------------
VAR1:=MA(CLOSE,N);{对“VAR1”赋值}
VAR2:=MA(CLOSE,2*N);{对“VAR2”赋值}
VAR3:=MA(CLOSE,3*N);{对“VAR3”赋值}
VAR4:=MA(CLOSE,4*N);{对“VAR4”赋值}
VAR5:=MA((VAR1+VAR2+VAR3+VAR4)/4,5);{一条多条均线的平均线}
上轨:=VAR5*1.08;{在均线“VAR5”上加上8%的幅度变成“上轨”}
下轨:=VAR5*0.92; {在均线“VAR5”上减去8%的幅度变成“下轨”}
{多头买入} ENTERLONG:CLOSE<>
{多头卖出} EXITLONG:CLOSE>上轨;
---------------------------------------------------

5.测试通过,退出;
6.〖Ctrl〗+〖E〗,打开“五彩K线指示”---“均线通道”;
7.查看效果,不满意就修改参数一直到满意为止;
8.删除指示:快捷键〖Ctrl〗+〖H〗;鼠标左键选中指示图标,按〖Delete〗,或者点击鼠标右键,在弹出的菜单中选“删除交易系统指示”。

3.5 颜色参数应用:“MACD”K线
ag改路单|注册名称:MACDK
简称:“MACD”K线
----------------------------
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACDDIF-DEA)*2,COLORSTICK;
D1:=EMA(C,3)-EMA(C,8);
D2:=EMA(O,3)-EMA(O,8);
D3:=EMA(H,3)-EMA(H,8);
D4:=EMA(L,3)-EMA(L,8);
DRAWICON(CROSS(D1,DIF) AND DIF<0 ,D4-0.1,10);
STICKLINE(D1>=D2,D1,D2,8,0),COLOR0055AA;
STICKLINE(D1<=D2,D1,D2,8,0),COLOR006600;
STICKLINE(D1>=D2,D1,D2,5,0),COLOR0077CC;
STICKLINE(D1>=D2,D1,D2,3,0),COLOR0099DD;
STICKLINE(D1>=D2,D3,D4,0,0),COLOR00BBFF;
STICKLINE(D1<=D2,D1,D2,5,0),COLOR009900;
STICKLINE(D1<=D2,D1,D2,3,0),COLOR00BB00;
STICKLINE(D1<=D2,D3,D4,0,0),COLOR00EE00;
------------------------------
示图

颜色参数不是函数,它描述待画图形的颜色,将其插入到每个ag改路单|注册ag改路单|注册后面,用逗号分隔开。
常用颜色参数有:
COLORBLACK 黑色
COLORBLUE 蓝色
COLORGREEN 绿色
COLORCYAN 青色
COLORRED 红色
COLORMAGENTA 洋红色
COLORBROWN 棕色
COLORLIGHTGRAY 淡灰色
COLORGRAY 深灰色
COLORLIGHTBLUE 淡蓝色
COLORLIGHTGREEN 淡绿色
COLORLIGHTCYAN 淡青色
COLORLIGHTRED 淡红色
COLORLIGHTMAGENTA 淡洋红色
COLORYELLOW 黄色
COLORWHITE 白色
颜色描述符还可以自定义颜色,格式为COLOR+“RRGGBB”:RR、GG、BB表示红色、绿色和蓝色的分量,每种颜色的取值范围是00-FF,采用了16进制。
例如:MA5:MA(CLOSE,5),COLOR00FFFF表示纯红色与纯绿色的混合色:COLOR808000表示淡蓝色和淡绿色的混合色。
(参见《附件》--颜色代码表)

3.6 新增函数应用(horcalc)
函数: HORCALC(X)
说明: 数据项:100-HIGH,101-OPEN,102-LOW,103-CLOSE,104-VOL,105-涨幅
计算方式:0-累加,1-排名次
权重:0-总股本,1-流通股本,2-等同权重,3-流通市值
用法: HORCALC(板块名称,数据项,计算方式,权重)
例如: HORCALC('自选股',103,0,1);以自选股板块股票的总股本为权重,以收盘价为数源进行累加。

ag改路单|注册名称:zdkx
ag改路单|注册描述:自定指数K线
参数:(最小值)(最大值)(缺省值)
#n: 1 100 10
---------------
高:=HORCALC('湖北板块',100,0,1);
开:=HORCALC('湖北板块',101,0,1);
低:=HORCALC('湖北板块',102,0,1);
收:=HORCALC('湖北板块',103,0,1);
自定K线: DRAWKLINE(高,开,低,收);
MA(自定K线,N);
---------------

ag改路单|注册说明:
1.用于制作自定义指数、自设板块指数K线。
2.先制作自定义板块,“Ctrl+z”,填写好板块名称和简称(数字);
3.“板块名称”须用单引号,如'自选股'、'庄股';
4.起始位为1000点(下载到本地数据);
5.板块内不要含有太多的股票数量,以免影响速度;

3.7 新增函数应用(blocksetnum)
函数: BLOCKSETNUM(板块名称)
说明: 统计板块中股票数量
用法: BLOCKSETNUM(板块名称)
注意:板块名称要用单引号
例如: BLOCKSETNUM('ST板块'),返回“ST板块”数量。

ag改路单|注册名称:STPM
ag改路单|注册描述:个股在st板块内排名
--------------
板块股数量:BLOCKSETNUM('ST板块'),NODRAW;
ST涨幅排名:HORCALC('ST板块',105,1,2);

说明:
NODRAW是不输出线型只输出数值命令,用于多ag改路单|注册不兼容坐标;
常用的语句
1)今收盘对于N日内最低收盘价的涨幅(%)(c-llv(c,n))/llv(c,n)*100;
2)今收盘价对于N日最高收盘价的跌幅(%)(HHV(C,N)-C)/HHV(C,N)*100;
3)股价在过去N日内运行空间的相对位置 (C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;
4)股价上方N1%至N2%处的筹码(%)
aa:=winner(c+c*n2/100)*100;
bb:=winner(c+c*n1/100)*100;
aa-bb
5)股价下方N1%至N2%处的筹码(%)
(winner(c-c*n1/100)-winner(c-c*n2/100))*100;
6)收盘价N%处的套牢盘 100-(winner(c*N/100))*100;
7)收盘价N%处的获利盘 winner(c*N/100)*100;
8)下影线 (MIN(O,C)-L)/L*100;
9)上影线 (h-max(o,c))/max(o,c)*100;
10)本周期的涨跌幅 (c-ref(c,1))/ref(c,1)*100;
11)振幅 (h-l)/l*100;
12)均线金叉(M.N为均线周期) cross(ma(c,m),ma(c,n))
13)均线多头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1>a2 and a2>a3 and a3>a4,3);
14) 均线空头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1<>
15)N日均线向下
aa:=ma(c,n);
bb:=ref(aa,2);
aa<>
16)向前N日至M日出现过均线死叉(P1<>
aa:=ma(c,p1);
bb:=ma(c,p2);
cc:=ref(cross(bb,aa),n);
count(cc,m);
17)今日成交量大于N日以来的均量 VOL>MA(VOL,N);
18)低位密集
A1:=COST(85);
A2:=COST(15);
A3:=A1-A2;
A4:=(A1+A2)/2;
A5:=A3/A4*100<10;
B1:=HHV(H,120);
B2:=LLV(L,120);
B3:=B1-B2;
B4:=(A4-B2)
A5 AND B4;
19)换手率 VOL/CAPITAL*100;
20)N日盈亏
V1:=VOL/SUM(VOL,N);
V2:=DMA(CLOSE,V1);
V3: (CLOSE-V2)/V2*100;?
1.成交量连续5天超过30天均量点
count(vol>ma(vol,30),5)=5

2.请老师编一选股ag改路单|注册;要求1;日均线多头排列的情况下(5,10,30,60。。。)2:5日。10日均线高度粘合--相等或相差1-2分钱,30均线与5,10均线相差1角以下。3:日量比大于2。先谢谢!!!
1.ma(c,5)>ma(c,10) and ma(c,10)>ma(c,30) and ma(c,30)>ma(c,60) and 。。。
2.abs(ma(c,5)-ma(c,10))<0.03 and abs(ma(c,30)-max(ma(c,5),ma(c,10)))<0.1
3.DYNAINFO(17)>2

3.威力雷达rad7日内连续上扬怎样编写?谢谢
V1:=(c/ref(c,1)-indexc/ref(indexc,1))*200;
RAD:=sum(v1,0);

count(rad>ref(rad,1),7)=7

威力雷达Mrad在7日内连续上扬怎样编写?谢谢
V1:=(c/ref(c,1)-indexc/ref(indexc,1))*200;
RAD:=sum(v1,0);

MRAD:=MA(RAD,30);

count(mrad>ref(mrad,1),7)=7

4.请问。10日内涨幅大于10%的选股ag改路单|注册怎样编?
c/ref(c,10)>1.1

5.如何编写股价在一个上涨或下跌的行情中第3次触及30日均线时发出提醒的ag改路单|注册?
M3:=MA(C,30);

N1:=BARSLAST(M3>REF(M3,1));

AA:=CROSS(C,M3);

COUNT(AA,N1)=3

6.请问:cysag改路单|注册中数值要小于-5,怎样编写到其他ag改路单|注册中.,谢谢!
(C-CYC(13))/CYC(13)*100<-5


7.当涨幅大于5%,要主图K线的实体的一半变为另一色。如何表达?
STICKLINE(c/ref(c,1)>1.05,(c+o)/2,c,10,1),coloryellow;

8.成交量连续3天涨的ag改路单|注册
COUNT(VOL>REF(VOL,1),3)=3

9.请问怎样用ag改路单|注册表示年线摆脱下降趋势出现向上拐头?
COUNT(MA(C,250)>REF(MA(C,250),1),3)=3

10.股价创出新高后,又调整到30日均线附近的选股ag改路单|注册如何编写?

COUNT(C>=HHV(C,N),5)=1 AND C/MA(C,30)>=1 AND C/MA(C,30)<1.02

11.怎么定义一阳线紧跟两阴线的函数?
ref(c,2)>ref(o,2) and ref(c,1)<>

12.60日线在过去的10天内涨跌幅度在 1%
COUNT(BETWEEN(ma(c,60),ref(ma(c,60),10)*1.01,ref(ma(c,60),10)*0.99),10)=10;

13.RSI(周线)在70天内第二次上穿80,如何编制?
COUNT(CROSS("RSI.RSI1#WEEK",80),70)=2

14.今天涨幅3%昨天涨幅2%前天涨幅1%的个股
(c-ref(c,1))/ref(c,1)>0.3 and (ref(c,1)-ref(c,2))/ref(c,2)>0.2 and (ref(c,2)-ref(c,3))/ref(c,3)>0.1

15.破5天线,3天后又重新站上5天线的个股
cross(ref(ma(c,5),3),ref(c,3)) and cross(c,ma(c,5))

16.今天一阳上穿5,10,30天线个股
cross(c,ma(c,5) and cross(c,ma(c,10)) and cross(c,ma(c,30))

17.3天内5天线上穿10天线,10天线上穿20天线的个股
count(cross(ma(c,5),ma(c,10)),3)>=1 and count(cross(ma(c,10),ma(c,20)),3)>=1

18.日macd翻绿3内又翻红的个股。
count(cross(0,"MACD.MACD" ),3)=1 and count(cross("MACD.MACD",0 ),3)=1

19.5天线拐头向下3天内又拐头向上的个股。
count(cross(ref(ma(c,5),1),ma(c,5)),3)=1 and count(cross(ma(c,5),ref(ma(c,5),1)),3)=1

20.收盘价比开盘价高出6%,当日涨幅超过6%,实体占整天振幅的80%以上
C/O>1.06 AND C/REF(C,1)>1.06 AND C-O>0.8*(H-L)


小ag改路单|注册ag改路单|注册编码集中问答(二)

1.怎样编制全市场平均价格ag改路单|注册

现在的指数不能说明市场真实平均价格,怎样写才准确呢?

沪股均价:"1A0002$AMOUNT"/"1A0002$VOL"/100;
深股均价:"399107$AMOUNT"/"399107$VOL"/100;
均价:("1A0002$AMOUNT"+"399107$AMOUNT")/("1A0002$VOL"+"399107$VOL")/100;

2.用股价选股

input:年(2004),月(8),日(31),最小价格(1),最大价格(2);
n:=DATEDIFF(((年-1900)*10000+月*100+日),DATE);//计算输入日期和现在日期周期
tj:REF(CLOSE,n)>最小价格 and REF(CLOSE,n)<>

3.
1,股价突破60日均线的选股ag改路单|注册,
2,和怎么选出一段时间以来的涨停板个股ag改路单|注册
1
cross(c,ma(c,60));
2
f:=ref(c,1)*1.1-c<0.01;
count(f,n)>0;//N天内出现过涨停

4.股价横盘,MACD金叉,然后股价创新底,MACD没死叉。
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=0.04
AND c"macd.dea";

5.过滤一个条件成立的信号

过滤:=(EMA(C,60)>EMA(C,30))>(EMA(C,60)>EMA(C,30)*1.05);

我需要这个信号以外成立的信号
过滤:=(EMA(C,60)>EMA(C,30))>(EMA(C,60)>EMA(C,30)*1.05);
not(过滤)
***
IF(过滤,0,1);

6.收盘价在20日均线之上,收盘价连升二天。
f:=c/ref(c,1);
count(c>ma(c,20) and f>1,2)=2;

7.求最大值?

在飞狐中如何求以下四个代数式中的最大值
a-b,b-c,a-c,d-c
MAX(A,B)只能返回A和B中的较大值?
MAX(MAX(A,B),MAX(C,D));

通用的“二次金叉”通式。

Jm:=CROSS("ag改路单|注册名称.ag改路单|注册线1","ag改路单|注册名称.ag改路单|注册线2");
JmCOUNT:=COUNT(Jm,BARSLAST("ag改路单|注册名称.ag改路单|注册线1(或ag改路单|注册线2)"大于或小于某数));
Jmtj:40*("ag改路单|注册名称.ag改路单|注册线1(或ag改路单|注册线2)"小于或大于某数));
Drawtext (Jmtj,40,'…………二次金叉');
条件选股:60*(Jmtj and …………),colorgreen;

例如(这里给出三个例子)
1、Macd在0轴线以下二次金叉
Jm:=CROSS("Macd.DIFF","Macd.DEA");
JmCOUNT:=COUNT(Jm,BARSLAST("Macd.DEA">=0));
Jmtj:40*("Macd.DEA"<0 and Count(JmCount=2,21)=1);
Drawtext (Jmtj,40,'Macd在0轴线以下二次金叉');
条件选股:60*(Jmtj and Slope(Ma(C,5),2)>0),colorgreen;
Drawtext (条件选股,50,'5日3%成功率:44.71%');

2、KD在60轴线以下二次金叉
Jm:=CROSS("KD.K","KD.D");
JmCOUNT:=COUNT(Jm,BARSLAST("KD.D">=60));
Jmtj:40*("KD.D"<60 and Count(JmCount=2,21)=1);
Drawtext (Jmtj,"KD.D",'KD在60轴线以下二次金叉');
条件选股:60*(Jmtj and Slope(Ma(C,20),3)>0),colorgreen;
Drawtext (条件选股,50,'5日3%成功率:50.3%');

3、SlowKD在30轴线以下二次金叉
Jm:=CROSS("SlowKD.K","SlowKD.D");
JmCOUNT:=COUNT(Jm,BARSLAST("SlowKD.D">=30));
Jmtj:28*("SlowKD.D"<30 and Count(JmCount=2,21)=1);
Drawtext (Jmtj,28,'SlowKD在30轴线以下二次金叉');
条件选股:50*(Jmtj and Slope(Ma(C,20),2)>0),colorgreen;?

10.求各位高手写一个选股ag改路单|注册!

N天,N日均线,以N角度向上或向下运行的均线。(分析家)

atan((ma(c,n)-ref(ma(c,n),N))/N); //值为正向上,值为负向下

11.K线中“低点不断抬高”和“低点不断降低”的ag改路单|注册如何编 ?

l>ref(l,1) and REF(L,1)>ref(l,2) and REF(L,2)>ref(L,N);;{N,5,1,999}
“低点不断抬高”
反之<>

12.符号编ag改路单|注册用

【】〓☆★○●◎◇◆□■△▲ⅠⅡⅢⅣⅤⅥⅦⅧⅨⅩ→←↑↓^§∧∨∪∩∈∞∝⊥∽√┣┫┻╋┼αβδωΩφΦΨΠ┳

13.当收盘价收在7天平均线上,K线都为阳线(红色),收盘价收在7天平均线下,K线都为阴线(录色),在主图怎样写?
stickline(c>=ma(c,7),c,o,7,0),colorred;
stickline(c>=ma(c,7),h,l,1,0),colorred;
stickline(c<>
stickline(c<>

14.20日内次高点
AA:=HHVBARS(C,20);
C=MAX(HHV(C,AA),REF(HHV(C,19-AA),AA+1));

15.要选出收市价离125天均线不远,
ABS(C-MA6)/MA6<=0.01

20.写均线MA1二次上穿MA4ag改路单|注册!
COUNT(CROSS(ma1,ma4),20)=2;
这是在网上摘录的,仅供参考
编写ag改路单|注册时常用的通式
应用 FXJ-4 的一些函数编写ag改路单|注册时,常用的通式:
{设A,B,R为三条曲线;N,M等为参数。如:A:ma(c,N) ; B:=ma(c,M); R:=c/ref(c,1)-1;等。。。}
{一.曲线在N天内的平均变化率}
Fa:=(A/ref(A,N)-1)/N; Fb:=(B/ref(B,N)-1)/N; Fr:=(R/ref(R,N)-1)/N;
{二.变动角}
∮a:=atan(Fa);    ∮b:=atan(Fb);  ∮r:=atan(Fr);
{三.曲线上相距N天的两点的连线的斜率}
Ka:=(A-ref(A,N))/N;   Kb:=(B-ref(B,N))/N; Kr:=(R-ref(R,N))/N;
{四.倾角}
∠a:=atan(Ka);   ∠b:=atan(Kb);   ∠r:=atan(Kr);
{五.交*点}
Cab:=cross(A,B);{交*} Jab:=longcross(A,B,N);{维持 -交*}
JYa:=between(A,N,M);{介于} FWa:=range(A,N,M);{范围}
{六.下拐点(由下向上转)}
xD1:=llvbars(A,N)=M;{以N日最低点}
xD2:=ref(count(A-ref(A,1)<=0,N)=N,M) and count(A-ref(A,1)>0,M)=M;{以M日变化量的正负}
xD3:=ref(count(∠a-ref(∠a,1)<=0,N)=N,M) and ∠a>0;{以当日变化角的正负}
{七.上拐点(由上向下转)}
sD1:=hhvbars(A,N)=M;{以N日最低点}
sD2:=ref(count(A-ref(A,1)>=0,N)=N,M) and count(A-ref(A,1)<0,M)=M;{以当日变化量的正负}
sD3:=ref(count(∠a-ref(∠a,1)>=0,N)=N,M) and ∠a<0;{以当日变化角的正负}
{八.位置(求得交*点/拐点到当前的周期)}
Wz1:=barslast(Cab);{第一(交*)点的位置}
Wz2:=ref(Wz1,Wz1+1)+Wz1+2;{第二(交*)点的位置}
Wz3:=ref(Wz1,Wz2+1)+Wz2+2;{第三(交*)点的位置}
Wz4:=ref(Wz1,Wz3+1)+Wz3+2;{第四(交*)点的位置}
Wz5:=ref(Wz1,Wz4+1)+Wz4+2;{第五(交*)点的位置}
{Wzn:=ref(Wz1,Wz(n-1)+1)+Wz(n-1)+2;}
{九.曲线A叠加曲线B}
F:=A/ref(A,1)-1;{A的变化率}
Js:=ref(B,barscount(c));{叠加位置(初始)}
DJ:=sum(F,0)+1)*Js;{叠加曲线(初始位置)}
Jd:=ref(B,barslast(条件));{叠加位置(定点)}
Dh:=(sum(F,0)+1)*Jd;{叠加曲线(预定位置)}